Tareas #6187

Tareas #6160: Implementación de la solución tecnológica

Diseño e implementación del Firewall

Added by Diego Morales over 1 year ago. Updated over 1 year ago.

Status:NuevaStart date:04/27/2019
Priority:NormalDue date:
Assignee:TLecom% Done:

90%

Category:-Spent time:-
Target version:-

Description

Realizar el diseño del Firewall, implementarlo en el Router y realizar la documentación.

firewall.jpg (58 KB) Mariano Hernández, 05/08/2019 07:47 PM

4201

History

#1 Updated by Diego Morales over 1 year ago

  • Assignee changed from Mariano Hernández to TLecom

#2 Updated by Mariano Hernández over 1 year ago

Un firewall o cortafuegos es un dispositivo de hardware o un software que nos permite gestionar y filtrar la totalidad de trafico entrante y saliente que hay entre 2 redes u ordenadores de una misma red.

Si el tráfico entrante o saliente cumple con una serie de Reglas que nosotros podemos especificar, entonces el tráfico podrá acceder o salir de nuestra red u ordenador sin restricción alguna. En caso de no cumplir las reglas el tráfico entrante o saliente será bloqueado.

Básicamente la función de un firewall es proteger los equipos individuales, servidores o equipos conectados en red contra accesos no deseados de intrusos que nos pueden robar datos confidenciales, hacer perder información valiosa o incluso denegar servicios en nuestra red.

Así por lo tanto queda claro que es altamente recomendable que todo el mundo utilice un firewall por los siguientes motivos:

  1. Preservar nuestra seguridad y privacidad.
  2. Para proteger nuestra red doméstica o empresarial.
  3. Para tener a salvo la información almacenada en nuestra red, servidores u ordenadores.
  4. Para evitar intrusiones de usuarios usuarios no deseados en nuestra red y ordenador. Los usuarios no deseados tanto pueden ser hackers como usuarios pertenecientes a nuestra misma red.
  5. Para evitar posibles ataques de denegación de servicio.

Un firewall funciona basicamente haciendo que todo el tipo de tráfico que no esté en la lista permitida por el firewall, no entra ni sale de la computadora.

Para ello, un sistema de firewall contiene un conjunto de reglas predefinidas que permiten:

  • Autorizar una conexión
  • Bloquear una conexión
  • Redireccionar un pedido de conexión sin avisar al emisor

El conjunto de estas reglas permite instalar un método de filtración dependiente de la política de seguridad adoptada por la organización. Se distinguen habitualmente dos tipos de políticas de seguridad que permiten:

  1. Permitir solamente lo que yo quiero y prohibir el resto: “Todo lo que no es autorizado explícitamente está prohibido”.
  2. Permitir todos y después especificar que esta prohibido

El primer método es el más seguro y es el metodo que nosotros utilizamos aunque requiere de una definición precisa de las necesidades de comunicación de toda la red.

paginas usadas

https://geekland.eu/que-es-y-para-que-sirve-un-firewall/

#3 Updated by Victor Alem over 1 year ago

  • Parent task set to #6160

#4 Updated by Mariano Hernández over 1 year ago

Mariano Hernández escribió:

Al principio en nuestro firewall bloqueamos toda la información y permitíamos ssh a todas las maquinas tanto físicas como virtuales,pero después de un problema que tuvimos en el cual ingresaron a nuestra maquina virtual.
Decidimos que solo se podría ingresar a la maquina que contenía las maquinas virtuales y desde esa a las otras maquinas

config defaults
option syn_flood '1'
option input 'DROP'
option output 'ACCEPT'
option forward 'DROP'

Zona en la cual se encuentra el puerto 1.
config zone

option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan Servicios Voip'

Al poner reject en el input y forward se bloquea la información que venia desde internet en esta zona

config zone
option name 'wan'
option input 'REJECT'
option forward 'REJECT'
option mtu_fix '1'
option network 'wan wan6'
option output 'ACCEPT'

Con esta regla permitimos el DHCP en el puerto 68

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option dest '*'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'accesoDNS'
option src 'wan'
option dest 'lan'
option proto 'udp'
option dest_port '53'
option target 'ACCEPT'

con esta regla se permite las interfaces web a las cuales se tendra que ingresar por medio de un tunel

config rule
option name 'accesoweb'
option src 'wan'
option dest 'lan'
option dest_port '80 443'
option target 'ACCEPT'
option proto 'tcp'
option family 'ipv4'

config rule
option name 'accesoSSHjeff'
option src 'wan'
option proto 'tcp'
option family 'ipv4'
option dest_port '8112'
option dest_ip '164.73.226.195'
option target 'ACCEPT'
option dest 'lan'

config rule
option name 'DeniegoTodo'
option src 'wan'
option target 'DROP'
option dest 'lan'

config include
option path '/etc/firewall.user'

config forwarding
option dest 'wan'
option src 'lan'

config forwarding
option dest 'lan'
option src 'wan'

#5 Updated by Mariano Hernández over 1 year ago

  • % Done changed from 0 to 90

Also available in: Atom PDF