Certificados ssl para acceso web en los Mikrotik

Vamos a generar y usar un certificado auto firmado para el acceso a la interfaz web de los Mikrotik,de esta forma la contraseña de acceso y lo que se transmita por la red viaje encriptado.
Algo que hay que tener muy en cuenta, es que la fecha del equipo debe ser correcta, ya que sinó nos dará error el certificado.

Primero debemos tener instalado en nuestro equipo Openssl.

Ahora creamos la llave:

openssl genpkey -algorithm RSA -des3 -pkeyopt rsa_keygen_bits:2048 -out nombreservidor.pem

En este caso se creó una llave nombreservidor.pem de 2048bits.
Nos pedirá una clave, la cual deberemos luego repetir para verificar.

Ahora que tenemos nuestra llave, generamos el CSR para solicitar el firmado del certificado:

openssl req -new -key nombreservidor.pem -out nombreservidor.csr

Nos pedirá la clave usada anteriormente y los datos para el certificado, se deja una captura cómo ejemplo:

Ahora vamos a auto firmar nuestro certificado, un parametro a dar es cuanto tiempo queremos que sea válido nuestro certificado, en este caso lo será por 365 días.

openssl x509 -req -days 365 -in nombreservidor.csr -signkey nombreservidor.pem -out nombreservidor.crt

Nos pedirá la clave usada anteriormente y nos mostrará los datos del certificado.

Ya tenemos nuestro certificado auto firmado, ahora hay que subirlo al router, esto se hace a través de la interfaz web

Luego de subirlo, nos conectamos al mismo a través de una consola por ssh. Ahí hacemos lo siguiente:

/certificate import file-name=nombreservidor.crt

les pide la clave de la key

/certificate import file-name=nombreservidor.pem

vuelven a ingresar la clave de la key

/certificate print

Ahí veremos los certificados instalados.

Lo que falta es asignarle el certificado al servicio:

/ip service set www-ssl certificate=cert1
/ip service set www-ssl disabled=no

También hay que habilitar el servicio www-ssl, eso se hace en la interfaz web desde:

IP-> Services