Configuración VLAN en RouterOS de Mikrotik

El escenario en el que nos vamos a basar, es que tenemos definidas distintas VLAN, y la idea es que usaremos el router para hacer reglas que nos permitan o no, pasar de una VLAN a otra. Para ello vamos a tener que dividir nuestra red en sub-redes, conde cada sub-red pertenecerá a una VLAN.

Nos vamos a basar en el siguiente diagrama de ejemplo para su configuración:

Definimos las VLANs con las siguientes subredes:
  • VLAN 2 – 10.10.20.0/24
  • VLAN 3 – 10.10.30.0/24
  • VLAN 4 – 10.10.40.0./24

Configuración de ejemploa en el router MikroTik:

Ingresamos a través de la consola, creamos las VLAN y las asiganmos a una interfaz:

/interface vlan
add name=VLAN2 vlan-id=2 interface=ether1 disabled=no
add name=VLAN3 vlan-id=3 interface=ether1 disabled=no
add name=VLAN4 vlan-id=4 interface=ether1 disabled=no

Luego a cada VLAN le asignamos una red:

/ip address
add address=10.10.20.1/24 interface=VLAN2
add address=10.10.30.1/24 interface=VLAN3
add address=10.10.40.1/24 interface=VLAN4

Luego conectaremos la interfaz seleccionada, con la boca del switch que donde tenemos configurada cómo "trunk"

Referencia:
http://wiki.mikrotik.com/wiki/Manual:Interface/VLAN